<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":0,"applicationTime":200,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81915513-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-7bf9e355b46ff060654c148212a35d40cb49b73381f27a9833dcc432fff1c97a.css' rel='stylesheet'>
<title>RebelGrove  -  McCready: 10 Weekend Thoughts presented by Harry Alexander</title>
<meta content='RebelGrove  -  McCready: 10 Weekend Thoughts presented by Harry Alexander' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-28f7e9f8b5e36d846a0976742fba6bb1a7dd9adc2006371d3f80e9792d3b44c3.css" />


<script src="https://cdn.rivals.com/production/assets/lib-12381f29bb2a6e1cd6ab2484aa7e729e8f72a6f1457e3a239ac156581f11a919.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-ae47702e860d0208681b49a40d344e1f884d9a27b8119a9a66ea1c0cc6579d18.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="g5qaxFzDV38bdG+azZrH6YnHmlqPqd9FWmbqjim0oQ6QsnGCy8dlznVSAWz+V2M6KnySOXkFlb6RDT9P5YRSSA==" />
<script>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</script>
</script>

<script>
  (function () {
    'use strict';
    angular.module('rivals').factory('baseAppSettings', function () {
  
      var getPremiumIcon = function() {
        return "";
      };
  
      var singleSiteApp = function() {
        return "false";
      };
  
      return {
        getPremiumIcon: getPremiumIcon,
        singleSiteApp: singleSiteApp
      };
    });
  }).call(this);
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://olemiss.rivals.com/news/mccready-10-weekend-thoughts-presented-by-harry-alexander-165' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/zyefzdyl8ibelors9gy4' property='og:image'>
<meta content='10 Thoughts: Lots of Ole Miss football, recruiting, Jaemyn Brakefield, Big Ten picks, AFC predictions, links and more.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2019-08-04 16:49:35 -0500' property='article:published_time'>
<meta content='2019-08-04 16:49:38 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "olemiss.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='olemiss contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .olemiss #programming > h1 {
      background-color: #003366 !important; } }
  .olemiss .wrapper-container .team-colors-line {
    background-color: #C7180C; }
  .olemiss img.custom-premium-icon, .olemiss .custom-premium-icon, .olemiss img.custom-premium-white-icon, .olemiss .custom-premium-white-icon,
  .olemiss img.custom-premium-gallery-icon, .olemiss .custom-premium-gallery-icon, .olemiss .premium-icon-container {
    display: none; }
  .olemiss .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #003366; }
    .olemiss .team-colors-line .color {
      width: 33.33%; }
    .olemiss .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .olemiss .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .olemiss .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .olemiss .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .olemiss .team-colors-line.header {
      height: 6px; }
  .olemiss > header .notification-link .count-container {
    background-color: #003366 !important; }
  .olemiss > header .wrapper-container {
    background-color: #003366 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .olemiss > header .wrapper-container {
        border-bottom: 6px solid #C7180C !important; } }
  .olemiss > header .invalid-email-banner {
    background-color: #003366;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .olemiss > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .olemiss > header .invalid-email-banner a:hover {
      color: #C7180C; }
  @media screen and (max-width: 767px) {
    .olemiss > header .mobile-header {
      background-color: #C7180C !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .olemiss > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .olemiss > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .olemiss > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .olemiss > header .nav-row > ul,
    .olemiss > header .third-nav {
      background-color: white !important; }
    .olemiss > header .dropdown-toggle > i.fa {
      color: #003366 !important; } }
  .olemiss > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #003366; }
  
  .site-primary-font-color {
    color: #003366; }
  
  .site-primary-background-color {
    background-color: #003366; }
  
  .site-secondary-font-color {
    color: #C7180C; }
  
  .site-secondary-background-color {
    background-color: #C7180C; }
  
  .team-background-image {
    background-image: linear-gradient(rgba(0, 51, 102, 0.4), rgba(0, 51, 102, 0.4)), url();
    background-repeat: no-repeat;
    background-position: center; }
  
  :root {
    --primary-color: #003366;
    --secondary-color: #C7180C;
    --accent-color: #003366;
    --button-color: #003366;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init(false,"olemiss")' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Ole Miss" class="site-header" ng-class="ctrl.teamSite ? &quot;team&quot; : &quot;no-team&quot;" href="https://olemiss.rivals.com/"><img src="https://res-4.cloudinary.com/rivals/image/upload/mbudrdnts6b78gb3njix" alt="Mbudrdnts6b78gb3njix" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span class='upsell-text'>
            Join the team!
          </span>
          <a ng-href='{{ ctrl.subscribePath + ctrl.utmParams }}'>
            Subscribe
          </a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://olemiss.rivals.com/">Home</a></li>
        <rv-forum-navigation site-identifier="&#39;olemiss&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://olemiss.rivals.com/">Home</a></li>
        <rv-forum-navigation site-identifier="&#39;olemiss&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733132,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "McCready: 10 Weekend Thoughts presented by Harry Alexander"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@Rivals' name='twitter:site'>
<meta content='McCready: 10 Weekend Thoughts presented by Harry Alexander' name='twitter:title'>
<meta content='10 Thoughts: Lots of Ole Miss football, recruiting, Jaemyn Brakefield, Big Ten picks, AFC predictions, links and more.' name='twitter:description'>
<meta content='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/zyefzdyl8ibelors9gy4' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":109,"legacy_id":1036,"name":"RebelGrove","friendly_name":"Ole Miss","annual_discount":null,"subdomain":"olemiss","primary_color":"003366","secondary_color":"C7180C","font_color":"ffffff","short_name":"olemiss","maple_ncaaf_team_id":77,"maple_ncaaf_endpoint":"ncaaf/teams/mmo","maple_ncaab_team_id":365,"maple_ncaab_endpoint":"ncaab/teams/mbf","maple_college_id":77,"google_analytics_id":"UA-81915513-1"}, true, 111, nil, {"id":46,"primary_color":"003366","secondary_color":"C7180C","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":false,"header_name":"","header_logo_cloudinary":"mbudrdnts6b78gb3njix","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81915513-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":true,"other_content":true,"site_id":109,"created_at":"2016-11-23T13:38:42.214-06:00","updated_at":"2019-01-14T18:59:59.195-06:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"FanFuturecastLeaderboard","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"forums_link_url":"https://olemiss.forums.rivals.com","scoreboard_scores_id":null,"scoreboard_photos_id":null,"aol_player_id":"5964f146b90afb37c877a576","aol_company_id":"595e67f22a30cb7ee3e5393a","ad_frequency":5,"display_twitter_follow":false,"display_fb_follow":false,"follow_twitter_handle":null,"follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true,"promo_popup_on":false,"facebook_developer_id":null,"customized_tos":[],"show_survey_popup":false,"survey_popup_link":null,"header_bottom_border_style":"solid","premium_icon_url":null,"customized_upsell_banner_text":null,"custom_premium_icon_enabled":null,"email_logo_cloudinary":null},&#x000A;"5964f146b90afb37c877a576", "595e67f22a30cb7ee3e5393a", "rivals", 15000, false, {"id":14,"user_id":757,"site_id":109,"updated_at":"2015-12-22T07:03:53.660-06:00","publisher_name":"Neal McCready","first_name":"Neal","last_name":"McCready","site_title":"Publisher","bio":null,"twitter_handle":null,"image_url":null,"publisher_name_and_title":"Neal McCready, Publisher","site_name":"RebelGrove","site_short_name":"olemiss","has_edited_profile":false})'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' premium_icon='null' profile_page='false' referral_code='referralCode' team='false'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":29,"image_id":2278556,"url":"http://www.craddockoil.com/","position":1,"site_id":109,"created_at":"2016-01-12T11:06:39.594-06:00","updated_at":"2018-08-23T06:51:04.113-05:00","image_url":"https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/mmv9jdoqs6aipcl7bguv"}' class='ad-one'></rv-custom-ad>
<rv-custom-ad ad='{"id":301,"image_id":2345801,"url":"https://www.cannonmotorcompany.com/","position":2,"site_id":109,"created_at":"2017-12-04T06:26:16.313-06:00","updated_at":"2018-10-30T10:23:48.440-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/dnwxgt5sbuw4w7br7mqs"}' class='ad-two'></rv-custom-ad>

<rv-forums ad-referer='https://olemiss.rivals.com/news/mccready-10-weekend-thoughts-presented-by-harry-alexander-165' base-api-url='https://olemiss.forums.rivals.com/' forums-url='https://olemiss.forums.rivals.com' homepage='false' pub-ad='{"id":301,"image_id":2345801,"url":"https://www.cannonmotorcompany.com/","position":2,"site_id":109,"created_at":"2017-12-04T06:26:16.313-06:00","updated_at":"2018-10-30T10:23:48.440-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/dnwxgt5sbuw4w7br7mqs"}' size='size' space-id='2022733132' subscribed-user='subscribedUser'></rv-forums>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://olemiss.rivals.com/news/mccready-10-weekend-thoughts-presented-by-harry-alexander-165/printable' site-name='RebelGrove'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2019-08-04 16:49:35 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2065560/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>McCready: 10 Weekend Thoughts presented by Harry Alexander</h2>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/jpdf8m7pkjfm54zh3kjy','https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto/jpdf8m7pkjfm54zh3kjy')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/jpdf8m7pkjfm54zh3kjy" alt="Jpdf8m7pkjfm54zh3kjy" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>10 Weekend Thoughts is presented by Harry Alexander.</figcaption>
</div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='author-name'>
Neal McCready
&bull;
</span>
<span class='type-sm'>RebelGrove</span>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='author-name'>Publisher</span>
</span>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">This was a punch to the gut. <br><br>I checked in with a law enforcement official for updates on the latest mass shooting. The reply: “You’ll have to be more specific regarding which massacre you’re referring to.”</p>&mdash; Josh Campbell (@joshscampbell) <a href="https://twitter.com/joshscampbell/status/1158015434777481217?ref_src=twsrc%5Etfw">August 4, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>It's hard to focus on sports today. </p><p>I think that means I'm human. Since the last time I published this piece, America has been home to three mass shootings. Gilroy, Calif.; El Paso, Texas; and Dayton, Ohio, have been left to deal with the aftermath of senseless violence.</p><p>I'm not smart enough to solve the problem. Hell, I'm not smart enough to diagnose it. However, I know thoughts and prayers aren't enough. Thoughts and prayers are nice, but they're platitudinal. They accomplish nothing. </p><p>Nothing is changing. Nothing. I know I'm not even horrified anymore when I see the news. I'm numb to it. It happens so routinely that one can't completely absorb what happened at one mass shooting before another occurs. I can't be alone. </p><p>My kids start school this week. There won't be many days I won't think, "God, I hope nothing happens at school." I'll start walking into stadiums in four weeks, and each time, I'll wonder if today's the day some nut sees how many people he can kill before the tables are turned on him. </p><p>For I know, eventually, at this pace, one of these horrific events is going to impact me or someone close to me. That's just the law of averages, right? </p><p>I won't blame the last week on Donald Trump any more than I'll blame Bill Clinton for Columbine or Barack Obama for Sandy Hook. I won't blame it all on guns. I respect the Second Amendment, even if I wonder if the founding fathers truly had some of the modern weapons in mind when they wrote that incredible document. I won't completely blame mental illness, as our society likely treats mental illness better today than it ever has before. Further, I'll have a bad day here and there, and I've never thought about walking into a Wal-Mart and seeing how many people I could kill. </p><p>However, the president's Twitter feed remains ridiculous, as does the rhetoric from the 20 or so candidates trying to earn the right to run against him next November. Everyone hates everyone, or so it seems. Politically, the country is racing to the extremes.</p><p>I read Twitter and there's more racism of multiple forms than I can keep up with. Whites hate Hispanics. Whites hate blacks. Blacks hate whites. Conservatives ridicule liberals. Liberals lambast conservatives. Most media coverage seems incredibly biased, one way or the other. </p><p>I'm convinced the violent video games desensitize social outcasts from the realities of mass murder. As someone who has never owned a gun, I don't understand the need for some to accumulate weaponry that has nothing to do with hunting or self-protection. </p><p>Like I said, I don't know. I'm just a dumb sports writer. </p><p>And you come here for sports, so it's sports I shall write about. Forgive me if my thoughts are sort of elsewhere. I suspects many of yours are too. </p><p>After all, the teams that lose the games I'll cover and you'll watch this fall won't die or anything. They'll go home, watch film and try again the next week. </p><p>The ramifications of what is happening in our country right now are far more permanent. </p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/g6jgtqdmtygxwzq79vxu','https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto/g6jgtqdmtygxwzq79vxu')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/g6jgtqdmtygxwzq79vxu" alt="G6jgtqdmtygxwzq79vxu" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Rich Rodriguez, shown here coaching Arizona in 2017, is going through his first fall camp as Ole Miss' offensive coordinator. (USA Today Sports)</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><b>1. Rich Rodriguez arrived in Oxford and immediately began trying to redefine Ole Miss’ offensive personality.</b> </p><p>Specifically, Rodriguez wanted the Rebels’ offense to play with “a hard edge.”</p><p>“That’s part of the goal,” Rodriguez said. “We’ve got to be the most disciplined, best conditioned, hardest playing team in America. On offense, we have to do that because we don’t have experience. We have talent but we’re not going to have experience. So what’s going to be our edge? It has to be the way we play. This camp, the next three weeks, is going to be partly developing that mentality.”</p><p>That edge, Rodriguez said, comes with an approach the players take and the coaches demand. </p><p>“Sometimes it’s misconceived that you’re beating the crap out of each other in practice all the time, and it’s not that at all,” Rodriguez said. “Obviously, when we put pads on, we’ve got to be physical, but it’s about your approach. We have to make sure that everything we do for a practice or a meeting or a walk-through standpoint, there’s great focus on it. Any really good program has that edge. That can come irregardless of experience. We have to demand and our coaches will.”</p><p>Of course, there’s a lot of production Rodriguez and the Ole Miss offense must replace. Rodriguez refers to that as a challenge, adding the installation of new systems on both sides of the ball only enhances the difficulty of the Rebels’ endeavor. </p><p>“That makes really everybody a freshman in my eyes,” Rodriguez said, “even the guys who were here. They don’t know what they don’t know as far as the system goes.”</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/z7z9sidwambjaq7epzh3','https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto/z7z9sidwambjaq7epzh3')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/z7z9sidwambjaq7epzh3" alt="Z7z9sidwambjaq7epzh3" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Matt Corral (USA Today Sports)</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><b>2. More specifically, Rodriguez spends a large part of his days with Ole Miss’ quarterback room, one that couldn’t be much younger. </b></p><p>Priority One is getting Matt Corral ready for his first college start. </p><p>“He’s got a little edge to him, which is good,” Rodriguez said with a laugh. “I’d rather say ‘Whoa’ than ‘Sic ‘em.’ He’s got all the talent you’d want. Football is important to him. He wants to be really good. Sometimes I forget he’s just a redshirt freshman because everybody else in that room is a true freshman. I’ve loved working with him so far. It’s an important camp and I have to make sure I don’t put too much on his plate.”</p><p>At the same time, Rodriguez doesn’t have the benefit of being overly patient. Corral has to be ready on Aug. 31, and in reality, so do one or two of the freshmen behind him. </p><p>“There’s going to be quite an interesting camp for all of them,” Rodriguez said. “There’s going to be true freshmen that play quarterback for Ole Miss at some point.”</p><p>Rodriguez said he won’t really know who’s ahead of who until they play in a game. </p><p>“I think the talent is there,” Rodriguez said. “You’d like to, unless the guy is just super talented, redshirt freshman quarterbacks. But that’s not the case. We have some talent there and some of them have to play early.”</p><p><br></p>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p><b>3. Rodriguez is known nationally for his spread offense, one he launched in 1986 at Salem (W. Va.) College.</b> He perfected it at Tulane and Clemson before becoming the head coach at West Virginia. Through stints at Michigan and Arizona, Rodriguez’s offensive philosophies became mainstream. </p><p>For his part, however, Rodriguez said he doesn’t force players to fit a scheme. Instead, he tries to build his offense around his players’ talents. </p><p>“Even though you could recruit (to Salem), you’re not going to recruit great skill position players,” Rodriguez said. “You better just get the best players you can get and see what happens. I’ve been very fortunate the places I’ve been to be able to have enough skill level talent to adjust to what (defenses) do. </p><p>“Twenty years ago, it was new and different. Now people are doing similar stuff, so the challenge for us was to find out what we can do that’s maybe a little different, a little new and not as prevalent in college and pro football and see what happens with that. We’re experimenting a little bit.”</p><p>Rodriguez said he thinks the Rebels have the talent in house to do some of those things. </p><p>“Check back with me in about two weeks,” Rodriguez said. “I’m always optimistic the first day of camp but in about two weeks, we’ll have a pretty good feel.”</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/yi74u3w7kkif3olsddo1','https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto/yi74u3w7kkif3olsddo1')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/yi74u3w7kkif3olsddo1" alt="Yi74u3w7kkif3olsddo1" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Ole Miss' Jaylon Jones (31) celebrates a kickoff return for touchdown in the Rebels' win over Texas Tech last September in Houston. (USA Today Sports)</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><b>4. Jaylon Jones won’t say he’s 100 percent healthy.</b> </p><p>Everyone else around the Ole Miss program will say the talented defensive back/return specialist is back, but Jones won’t say it until he gets his knee brace off. </p><p>Jones tore his ACL in the Rebels’ season-opening win over Texas Tech in Houston last September. </p><p>“It was (deflating) just knowing how much work I’d put in that summer before and how camp had gone,” Jones said. “It was God’s plan. I couldn’t question it. I had a little doubt after I got the news but after that, man, I thank my teammates and coaching staff and training staff for keeping my spirits high. I attacked the whole process.”</p><p>Jones said he dove into his rehab and pointed toward 2019, one that should see him play a huge role in Ole Miss’ defense under the direction of new defensive coordinator Mike MacIntyre.</p><p>“I’m a guy that really wants to learn the game,” Jones said. “A new playbook just means more studying. One thing I can say about Coach (MacIntyre) is every coach that comes in here has a playbook but Coach Mac, man, he’s a teacher. He really knows how to explain things. He’s hands-on. That 3-4, having Qaadir Sheppard and Sam Williams standing up, I see us being able to stop the run. On the back end, I don’t think anything’s change, but with the way they worked the spring, we’ve got a different kind of confidence and swagger.”</p><p>Jones knows the numbers from last season were rough. However, he said when he would watch film, he always noticed “one guy misplaced and we’d have to pay for that mistake. We have a lot of talent but with this 3-4 with Coach Mac, the way we’re going over plays and understanding concepts, route concepts and understanding schemes more, knowledge equals power and that equals success for us.”</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/tcrmpqy82ehi940jqj4k','https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto/tcrmpqy82ehi940jqj4k')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/tcrmpqy82ehi940jqj4k" alt="Tcrmpqy82ehi940jqj4k" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Jonathan Mingo</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><b>5. Jonathan Mingo arrived in Oxford in late May.</b> When Ole Miss had voluntary, player-led practices this summer, he worked with the second unit. After practices, however, he asked the starting defensive backs to stay and compete against him. Mingo wanted to get a feel for going against the top SEC cornerbacks and safeties, so he begged the Rebels’ best to hang around and provide that experience. </p><p>Mingo also used the work to build a relationship with Matt Corral. </p><p>“It seemed like every time he got a chance he’d throw to me,” Mingo said. “We’re getting our timing down. It’s about chemistry and connection and him knowing how I come out of my breaks.”</p><p>Corral’s spin rate has taken some adjustments on Mingo’s end. </p><p>“I have to focus on details, look the ball all the way in and just little small details,” Mingo said. “I just have to focus. I just want to show everybody I belong here and try to. Impress people.”</p><p>Mingo knows he and his fellow wide receivers have huge shoes to fill. DK Metcalf is in Seattle. A.J. Brown is with the Titans. Dawson Knox is in Buffalo. Still, Mingo isn’t bothered by expectations. </p><p>“Everyone is just trying to come in and make plays and be playmakers,” Mingo said. “That’s what we’re supposed to do — make plays on the ball and take advantage of opportunities when they come to us. We’re all coaching each other and pushing each other.”</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/dxqybmmgf69gu9iy4ror','https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto/dxqybmmgf69gu9iy4ror')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/dxqybmmgf69gu9iy4ror" alt="Dxqybmmgf69gu9iy4ror" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Jakivuan Brown (Rivals.com)</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><b>6. Ole Miss got a commitment Thursday from Horn Lake, Miss., linebacker <a href="https://n.rivals.com/content/prospects/2020/jakivuan-brown-203978">Jakivuan Brown</a>. </b>He was Ole Miss’ 23rd commitment for this class, prompting many to wonder just how many spots are left. </p><p>I’ll take a stab at it. If all commitments hold and everyone qualifies academically, Ole Miss has three spots left. That won’t happen. </p><p>Instead, I look for at least one academic casualty (no, I won’t name names) and I would expect somewhere between one and three of the current commitments to end up elsewhere. Why? Because that’s how recruiting works.</p><p>So, I’ll guess Ole Miss has six slots available, give or take one. The Rebels would love to add defensive linemen <a href="https://n.rivals.com/content/prospects/2020/mckinnley-jackson-180953">McKinnley Jackson</a> and <a href="https://n.rivals.com/content/prospects/2020/omari-thomas-184366">Omari Thomas</a>, and I believe Ole Miss leads for both. The Rebels would also love to sign Alabama commitment/defensive linemen <a href="https://n.rivals.com/content/prospects/2020/jah-marien-latham-234381">Jah-Marian Latham</a>, and I still maintain that could happen. </p><p>Ole Miss wants Oxford, Miss., tight end <a href="https://n.rivals.com/content/prospects/2020/jeremiah-pegues-209505">Jeremiah Pegues</a>, and that remains an Ole Miss-Auburn battle. The Rebels remain hot for Grenada, Miss., cornerback/MSU commitment <a href="https://n.rivals.com/content/prospects/2020/emmanuel-forbes-jr-234363">Emmanuel Forbes</a>, and that race is far from over. </p><p>After that, it’s a bit of a guessing game, though I suspect there are 15-20 names on Ole Miss’ list, guys who the Rebels would try to accommodate if they wanted to come. </p><p>August is a dead period, so my guess is things stay quiet for a while before heating up in September. </p><p>Bottom line for Ole Miss: Things are going extremely well for the 2020 class, as the Rebels are No. 15 in the Rivals rankings as of Sunday afternoon — with several highly-rated prospects very much still on the board.</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/dvc3uajopomdzmldxkn8','https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto/dvc3uajopomdzmldxkn8')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/dvc3uajopomdzmldxkn8" alt="Dvc3uajopomdzmldxkn8" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Jaemyn Brakefield (Nick Lucero/Rivals.com)</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><b>7. Huntington (W. Va.) Prep forward <a href="https://n.rivals.com/content/prospects/2020/jaemyn-brakefield-208614">Jaemyn Brakefield</a> was back on Ole Miss’ campus Thursday, a sure sign that the Rebels remain very much in the mix for the elite 2020 prospect.</b> </p><p>Brakefield did not commit to Ole Miss on the visit, which was not surprising. A source close to the program said he didn’t expect anything from Brakefield in the form of a decision anytime soon. </p><p>“They definitely think I can come in and have a big impact right away,” Brakefield told Rivals earlier this summer. </p><p>Brakefield has spent part of his summer training in Madison, Miss. At one point, the 6-foot-8 Brakefield contemplated reclassifying. He has since decided to play another season at Huntington Prep. </p><p>Per sources, Brakefield, who is ranked No. 33 nationally by Rivals, will take an official visit to Louisville next month. Michigan State, Memphis and several SEC schools have been involved with Brakefield this summer. Brakefield said he plans to wait until April to make a decision.</p><p>“I want to see how things develop,” Brakefield said. </p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/hijffa0mhn5eentduquk','https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto/hijffa0mhn5eentduquk')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/hijffa0mhn5eentduquk" alt="Hijffa0mhn5eentduquk" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Iowa's Kirk Ferentz (USA Today Sports)</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><b>8. With the college season drawing closer and closer, I’ll use this space to predict the outcomes of leagues I know almost nothing about.</b> I’ll start with the Big Ten.</p><p><b>Big Ten East</b><br></p><p>1. Ohio State</p><p>2. Michigan State</p><p>3. Michigan</p><p>4. Penn State</p><p>5. Indiana</p><p>6. Maryland</p><p>7. Rutgers</p><p><b>Big Ten West</b><br></p><p>1. Iowa</p><p>2. Wisconsin</p><p>3. Nebraska</p><p>4. Northwestern</p><p>5. Minnesota</p><p>6. Purdue</p><p>7. Illinois</p><p><b>Big Ten Champion</b>: Ohio State</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/inseanrbzbgk3pgbogru','https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto/inseanrbzbgk3pgbogru')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/inseanrbzbgk3pgbogru" alt="Inseanrbzbgk3pgbogru" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Kansas City's Patrick Mahomes (USA Today Sports)</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><b>9. I'll start my NFL predictions this week as well.</b> Bet accordingly. </p><p>Here are my predictions for the AFC this season:</p><p><b>AFC East</b><br></p><p>1. New England<br></p><p>2. Buffalo<br></p><p>3. New York Jets<br></p><p>4. Miami<br></p><p><b>AFC South</b><br></p><p>1. Houston<br></p><p>2. Indianapolis<br></p><p>3. Tennessee<br></p><p>4. Jacksonville<br></p><p><b>AFC North</b><br></p><p>1. Cleveland<br></p><p>2. Pittsburgh<br></p><p>3. Baltimore<br></p><p>4. Cincinnati<br></p><p><b>AFC West</b><br></p><p>1. Kansas City</p><p>2. San Diego<br></p><p>3. Oakland<br></p><p>4. Denver<br></p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/kwtjt5mvnsmjmztstezx','https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto/kwtjt5mvnsmjmztstezx')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/kwtjt5mvnsmjmztstezx" alt="Kwtjt5mvnsmjmztstezx" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Larry Rountree (Jordan Kodner)</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><b>10. We'll have coverage of Ole Miss football and whatever else comes about this week on RebelGrove.com. </b>Until then, here are some links of interest to me _ and hopefully, to you _ for your reading pleasure:</p><p><a href="https://theathletic.com/1113817/2019/08/04/missouri-tigers-football-larry-rountree-running-back/"></a><a href="https://theathletic.com/1113817/2019/08/04/missouri-tigers-football-larry-rountree-running-back/">Carrying the load: From Carolina to Columbia, how Larry Rountree became Missouri’s featured running back – The Athletic</a></p><p><a href="https://www.espn.com/college-football/story/_/id/27265149/crazy-how-things-work-kelly-bryant-journey-clemson-missouri">'It's crazy how things work out' -- Inside Kelly Bryant's journey from Clemson to Missouri - espn.com</a></p><p><a href="https://auburn.rivals.com/news/will-hastings-ready-to-give-everything-to-auburn-tigers-football-malzahn">AuburnSports - Hastings ready to 'give everything' to Auburn</a></p><p><a href="https://theathletic.com/1100668/2019/07/29/mike-locksley-maryland-new-mexico-journal/">Inside the journal where Mike Locksley keeps his hard lessons from New Mexico – The Athletic</a></p><p><a href="https://theathletic.com/1108274/2019/08/01/if-you-dont-look-right-you-dont-play-right-how-longtime-equipment-manager-tony-medlin-built-his-bears-legacy/">‘If you don’t look right, you don’t play right’: How longtime equipment manager Tony Medlin built his Bears legacy – The Athletic</a></p><p><a href="https://theathletic.com/1101770/2019/07/28/a-man-on-an-island-inside-matthew-slaters-unique-training-camp-routines/">‘A man on an island’: Inside Matthew Slater’s unique training camp routines – The Athletic</a></p><p><a href="https://theathletic.com/1113945/2019/08/02/how-pitchers-exploit-the-cubs-offense-and-why-their-deadline-additions-and-ben-zobrist-could-be-the-elixir/">How pitchers exploit the Cubs’ offense and why their deadline additions (and Ben Zobrist?) could be the elixir – The Athletic</a></p><p><a href="https://theathletic.com/1112879/2019/08/02/scaredy-cat-eduardo-escobars-feline-fear-and-the-purrfect-hell-the-diamondbacks-put-him-through/">Scaredy cat: Eduardo Escobar’s feline fear and the purrfect hell the Diamondbacks put him through – The Athletic</a></p><p><a href="https://theathletic.com/1110927/2019/08/01/bowden-trade-deadline-grades-for-all-30-mlb-teams/">Bowden: Trade deadline grades for all 30 MLB teams – The Athletic</a></p><p><a href="https://theathletic.com/1110046/2019/08/01/rosenthal-the-trade-deadline-is-the-latest-example-of-the-life-getting-sucked-out-of-the-sport/">Rosenthal: The trade deadline is the latest example of the life getting sucked out of the sport – The Athletic</a></p><p><a href="https://www.ajc.com/blog/atlanta-braves/braves-front-office-and-ownership-deserve-round-applause/7euffUvsveg6KNpJkNk5aK/">Braves’ front office - and ownership - deserve round of applause</a></p><p><a href="https://www.espn.com/nba/story/_/id/27282369/you-plan-next-year-coaching-nba-where-stars-call-shots">'You can't plan beyond next year'- Coaching in an NBA where stars call the shots - espn.com</a></p><p><a href="https://theathletic.com/1112113/2019/08/02/the-downfall-of-paul-fenton-inside-the-gms-turbulent-14-months-with-the-wild/">The downfall of Paul Fenton: Inside the GM’s turbulent 14 months with the Wild</a></p><p><a href="https://www.propublica.org/article/university-of-illinois-financial-aid-fafsa-parents-guardianship-children-students">Parents Are Giving Up Custody of Their Kids to Get Need-Based College Financial Aid — ProPublica</a></p><p><a href="https://www.newyorker.com/magazine/2019/08/05/alan-dershowitz-devils-advocate">Alan Dershowitz, Devil’s Advocate | The New Yorker</a></p><p><a href="https://nypost.com/2019/07/28/trump-is-right-about-baltimore-and-the-democrats-know-it/">Trump is right about Baltimore — and the Democrats know it</a></p><p><a href="https://www.etonline.com/hannah-brown-is-a-bachelorette-for-the-modern-age-how-this-season-reinvented-the-franchise-129769">Hannah Brown Is a 'Bachelorette' for the Modern Age: How This Season Reinvented the Franchise </a></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Mike Leach wears cargos as religiously as Jim Harbaugh wears khakis &amp; you’ll never see the <a href="https://twitter.com/hashtag/WSU?src=hash&amp;ref_src=twsrc%5Etfw">#WSU</a> coach in nylon shorts. <br><br>“I don’t understand those. You jog around &amp; your stuff flaps all over the place. I’ve never liked those.”<br><br>Interpret “your stuff flaps around” how you’d like. <a href="https://t.co/r4TqZFAwtG">pic.twitter.com/r4TqZFAwtG</a></p>&mdash; Theo Lawson (@TheoLawson_SR) <a href="https://twitter.com/TheoLawson_SR/status/1157821086651654144?ref_src=twsrc%5Etfw">August 4, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://olemiss.rivals.com/news/mccready-10-weekend-thoughts-presented-by-harry-alexander-165/printable' site-name='RebelGrove'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='{"id":301,"image_id":2345801,"url":"https://www.cannonmotorcompany.com/","position":2,"site_id":109,"created_at":"2017-12-04T06:26:16.313-06:00","updated_at":"2018-10-30T10:23:48.440-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/dnwxgt5sbuw4w7br7mqs"}' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2019' site='{"id":109,"legacy_id":1036,"name":"RebelGrove","friendly_name":"Ole Miss","annual_discount":null,"subdomain":"olemiss","primary_color":"003366","secondary_color":"C7180C","font_color":"ffffff","short_name":"olemiss","maple_ncaaf_team_id":77,"maple_ncaaf_endpoint":"ncaaf/teams/mmo","maple_ncaab_team_id":365,"maple_ncaab_endpoint":"ncaab/teams/mbf","maple_college_id":77,"google_analytics_id":"UA-81915513-1"}' twitter-feed='{"id":109,"site_id":109,"handle":null,"list_name":null,"created_at":"2016-02-01T12:25:17.703-06:00","updated_at":"2016-02-01T12:25:17.703-06:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://olemiss.rivals.com/news/mccready-10-weekend-thoughts-presented-by-harry-alexander-165/printable' site-name='RebelGrove'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733132', 'https://olemiss.rivals.com/news/mccready-10-weekend-thoughts-presented-by-harry-alexander-165');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "McCready: 10 Weekend Thoughts presented by Harry Alexander";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("olemiss", 2065560, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":29,"image_id":2278556,"url":"http://www.craddockoil.com/","position":1,"site_id":109,"created_at":"2016-01-12T11:06:39.594-06:00","updated_at":"2018-08-23T06:51:04.113-05:00","image_url":"https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/mmv9jdoqs6aipcl7bguv"}' class='ad-one'></rv-custom-ad>
</div>
</div>

</div>
</main>
<footer>
<!-- t('footer.about_link', primary_host: primary_host) -->
<ul class='footer-links list-inline'>
<li>
<a href='/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='/news/member-services'>Help</a>
</li>
</ul>
<div class='logo-container'>
<div class='footer-logo'></div>
</div>
<div class='copyright-notice'>Certain data provided by STATS, LLC<br/>© 2019 Verizon Media. All rights reserved.</div>
</footer>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733132",
    c7: "https://olemiss.rivals.com/news/mccready-10-weekend-thoughts-presented-by-harry-alexander-165"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Folemiss.rivals.com%2Fnews%2Fmccready-10-weekend-thoughts-presented-by-harry-alexander-165&c5=2022733132&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
